Редактировать сообщение

RdpGuard Repack [image] _____ Год/Дата Выпуска: 2020
_____ Версия: 6.7.5/5.4.9
_____ Разработчик: NetSDK Software, LLC
_____ Сайт разработчика: xttps://rdpguard.com/
_____ Разрядность: 32bit, 64bit
_____ Язык интерфейса: Английский
_____ Таблэтка: RAMZEZzz
_____ Системные требования: Windows XP, Vista, 7, 8, 8.1, 10 and Windows Server 2003 (R2), 2008 (R2), 2012 (R2), 2016
_____ Описание: RdpGuard защищает от brute-force атак. Защищаемые протоколы и службы: RDP, FTP, IMAP, POP3, SMTP, MySQL, MS-SQL, IIS Web Login, ASP.NET Web Forms, MS Exchange, RD Web Access, VoIP/SIP, и т.д. Программа получает события из стандартного журнала Windows, и если количество неудачных попыток входа в систему с одного IP-адреса достигает установленного предела, IP-адрес злоумышленника будет заблокирован на указанный в настройках период времени. Блокирование IP-адреса осуществляется с помощью стандартного встроенного Windows Firewall. Таким образом, все операции реализованы стандартными средствами Windows, а программа только автоматически добавляет/удаляет IP-адреса в брандмауэр, благодаря чему поддерживается высокая производительность, совместимость и стабильность. Для конфигурирования имеется как GUI, так и интерфейс командной строки. Приложение написано на .Net 4, при отсутствии его необходимо будет установить. При блокировании/разблокировании/отказе входа можно назначить дополнительное действие. В программе можно задавать белые списки, например, для интрасети или удаленных офисов. Ввиду того, что brute-force атаки теперь производятся не только по стандартным, но и по всем открытым портам, актуальность использования данной программы очень высока.
_____ В ранних версиях Windows, т.е. Server 2008R2 и ниже, в событии отказа входа по RDP со стойким TLS-шифрованием не записывался клиентский IP-адрес (гениальное решение от Microsoft), тем не менее в 2008R2 программа умеет слушать порт и даже в этом случае корректно работает. Для еще более древних систем проблема решается установкой драйвера WinPcap, с которым программа умеет работать. Вероятно, какие-либо нестандартные 3rd-party Firewall не дадут RdpGuard работать нормально. В Server 2012 Microsoft решила эту проблему, поэтому в программе соответствующие костыльные настройки будут недоступны.
Скриншоты с боевого сервера

В версии 6.7.5 заработало контекстное меню на SIP-блокировках:
[свернуть]
Скриншоты окна About

[свернуть]

virustotal.com:
RdpGuard 6.7.5 pre-cracked.exe SHA256: 2d610945c88420e81b90213cecabf8b9c6875881a4dce83ea520aaf5d5513fd1
RdpGuard 5.4.9 pre-cracked.exe SHA256: a9f2e68116cb020291d8418005c6cb64609862f5f6e34f2a0822b1c2fef8eff7
Доп. информация: Репак представляет собой 7zip UPX sfx-архив, который сначала устанавливает оригинальную версию, а потом поверх нее ставит патч (вероятно некоторым антивирусам такое поведение не понравится). Можете распаковать и сделать эту же процедуру руками. Дополнительно репак прописывает в планировщике перезапуск службы RdpGuard каждые 7 дней. Опцию автоматической проверки новой версии лучше отключить.
repack history
2018-05-04 версии 4.8.9/5.2.3
2018-07-27 версия 5.3.5 - репак от автора крэка
2018-10-12 версия 5.4.9 (стабильная из версий 5.X.X)
2019-11-09 версия 6.1.7 (с зашитым ключом только для этой версии, т.е. официальная не ломаная)
2020-02-17 версия 6.6.7
2020-02-21 версия 6.6.7 V4
  1. восстановлена цифровая подпись пропатченного файла (самоподписанным сертификатом), чтобы до него не докапывался Windows Defender
  2. отложенный запуск службы для более стабильного запуска в высоконагруженных системах
2020-03-11 версия 6.7.5 (первая наиболее стабильная из всех 6.X.X версий)
[свернуть]

PS.
Если задача блокировать только подбор паролей на RDP-подключениях, то посмотрите в сторону бесплатной Cyberarms Security Software - Intrusion Detection for Windows с открытым исходным кодом на гитхабе.
Если задача иметь железобетонную стабильность, то смотрите в сторону IPBan тоже с открытым исходным кодом, но в ней нет бесплатного GUI, пример файла настроек для нее выложен в этой теме.
Также обращаю внимание, что более старые версии RdpGuard могут быть более стабильны, чем новые. Если ничего из новых "облачных" возможностей слежения за вами версий 6.X.X вам не нужно, используйте проверенные версии 5.X.X, например, 5.4.9.
Спасибо за понимание!